ISOSLAND

Games of the new generation " PS3 , PSVITA , XBOX ONE , PS4 , NSW ... and more" 

  • Tangledeep NSP

 #12147  by Cronos
 Wed Feb 06, 2019 8:48 pm
https://cdn01.nintendo-europe.com/media/images/11_square_images/games_18/nintendo_switch_download_software/SQ_NSwitchDS_Tangledeep_image500w.jpg



Description Tangledeep combines the 16-bit graphics and polish of classic RPGs with elements from roguelikes and dungeon crawlers to create a magical experience for players of all skill levels. Trapped in underground villages with no memory of the world at the surface, you must survive an ever-changing labyrinth to discover what lies above.

Experience rich, tactical, turn-based gameplay as you explore a sprawling dungeon that’s different each time you play. Tangledeep features a customizable job system and hundreds of collectible items that allow you to approach each playthrough in a totally new way!

Tangledeep NSP INFO
Release date: 31/01/2019
Publisher / Developer: Impact Gameworks
Genres: Adventure, RPG, Strategy
Format: NSP
Languages: MULTI (chinese, english, japanese)
Region: FREE / USA
SIZE : 663 MB
Link :
 #12184  by Black Sword
 Sun Feb 10, 2019 9:50 pm
caskalex wrote:
Sun Feb 10, 2019 6:08 pm
kja4kc wrote:Tinfoil says its a bad dump
I received a similar error.
what fw do you use ? more info to help you
 #12200  by caskalex
 Tue Feb 19, 2019 1:35 am
Black Sword wrote:
Sun Feb 10, 2019 9:50 pm
caskalex wrote:
Sun Feb 10, 2019 6:08 pm
kja4kc wrote:Tinfoil says its a bad dump
I received a similar error.
what fw do you use ? more info to help you
I am using firmware 5.1.

I have tried installing the nsp with the newest version of SXOS and tinfoil.
 #12205  by Black Sword
 Tue Feb 19, 2019 8:12 pm
caskalex wrote:
Tue Feb 19, 2019 1:35 am
Black Sword wrote:
Sun Feb 10, 2019 9:50 pm
caskalex wrote:
Sun Feb 10, 2019 6:08 pm


I received a similar error.
what fw do you use ? more info to help you
I am using firmware 5.1.

I have tried installing the nsp with the newest version of SXOS and tinfoil.
all latest games use fw 6.2 , try to upgrade then
 #12216  by caskalex
 Wed Feb 20, 2019 1:00 am
I upgraded my firmware to 6.2 and it works!

Thanks for the advice Black Sword.
 #12219  by Black Sword
 Wed Feb 20, 2019 7:50 pm
caskalex wrote:
Wed Feb 20, 2019 1:00 am
I upgraded my firmware to 6.2 and it works!

Thanks for the advice Black Sword.
you're welcome ;-)