ISOSLAND

Games of the new generation " PS3 , PSVITA , XBOX ONE , PS4 , NSW ... and more" 

  • The LEGO Movie 2 Videogame NSP + UPDATE + DLC

 #12293  by Cronos
 Mon Mar 04, 2019 7:45 pm
https://static.raru.co.za/news/header/7452.png



Description Lego Movie 2 Videogame is an action-adventure video game on the theme Lego developed by TT Fusion and published by Warner Bros. Interactive Entertainment.

The LEGO Movie 2 Videogame NSP + UPDATE + DLC INFO
Release date: 27/02/2019
Publisher / Developer: WB Games
Genres: Action, Adventure
Format: NSP
Languages: MULTI (chinese, dutch, english, french, german, italian, japanese, korean, russian, spanish)
Region: FREE / USA
SIZE : 4.9 GB
Link :
GDRIVE
http://sluppend.com/2qKK
update v65536
http://sluppend.com/2qLb
dlc Prophecy Pack
http://sluppend.com/2qND
PASS
byblacksword
 #12359  by ideefix
 Sat Mar 09, 2019 3:03 pm
Can you tell me where is that password needed?I thought that will be rar or zip file but it wasn't ,so I have downloaded and instal it straight on switch but looks like it is corrupted . what I doing wrong?Regards
 #12368  by Black Sword
 Sat Mar 09, 2019 8:48 pm
ideefix wrote:
Sat Mar 09, 2019 3:03 pm
Can you tell me where is that password needed?I thought that will be rar or zip file but it wasn't ,so I have downloaded and instal it straight on switch but looks like it is corrupted . what I doing wrong?Regards
have you install it with tinfoil ? what cfw you have ?
 #12377  by Ravendrake
 Mon Mar 11, 2019 4:12 pm
Hey,

same here - even with newest SX OS cant get it to work.
The file installs fine (both with tinfoil or sx os installer) but there is no game icon (just an black square). I can click and start and all that happens is "checking if hte software can be played"

I tried to install in Emunand if that is important to know.
 #12379  by Cronos
 Mon Mar 11, 2019 7:34 pm
Ravendrake wrote:
Mon Mar 11, 2019 4:12 pm
Hey,

same here - even with newest SX OS cant get it to work.
The file installs fine (both with tinfoil or sx os installer) but there is no game icon (just an black square). I can click and start and all that happens is "checking if hte software can be played"

I tried to install in Emunand if that is important to know.
maybe your sd card is corrupted , try another one and tell me ;-)