ISOSLAND

Games of the new generation " PS3 , PSVITA , XBOX ONE , PS4 , NSW ... and more" 

  • Pokémon Shield NSP / XCI

 #15977  by Cronos
 
https://s3.gaming-cdn.com/images/products/4076/orig/pokemon-shield-switch-cover.jpg



Description Get ready to explore Galar, a vast region with diverse environments, from peaceful countryside to modern cities to lush forests and snow-capped mountains. The humans and Pokémon living there cooperate in perfect harmony to develop local industries.

Once your partner Pokémon has been chosen, your journey can truly begin: you will need to capture, train and trade Pokémon to form a team that can triumph over the Arena Champions and make you the new Master of the Galar Region!
Pokémon Shield NSP / XCI INFO
Release Date: Nov 15, 2019
Developer: GAME FREAK
Category: Role-Playing (RPG), Adventure
Region: FREE / EUR
Languages: English, German, French, Spanish, Italian, Japanese, Chinese, Korean
FORMAT : NSP / XCI
SIZE : 9 GB
Link :
NSP FORMAT
GDRIVE
http://legeerook.com/2s0p
1FICHIER
https://ouo.io/KuylrU

XCI FORMAT
1FICHIER
https://ouo.io/fpgI2X

UPDATE v1.2.0 [NEW]
ONEDRIVE
http://raboninco.com/11IDk
1FICHIER
https://ouo.io/Ye1P5f

2 DLC Expansion Pass [NEW]
ONEDRIVE
http://raboninco.com/11IBP
1FICHIER
https://ouo.io/hM6CxB
 #15987  by Cronos
 
Paperwings wrote: Thu Nov 14, 2019 2:43 pm It's not working for me. I haven't use my switch in like a year, so It's probably outdated (it says that it's version 1.9). Any guidance on how to update it PLEASE?
This is what I see (link to an image) https://imgbbb.com/image/LgzmGt
Thanks in advance!
what's your fw version ?
 #15991  by Paperwings
 
Cronos wrote: Thu Nov 14, 2019 9:16 pm
Paperwings wrote: Thu Nov 14, 2019 2:43 pm It's not working for me. I haven't use my switch in like a year, so It's probably outdated (it says that it's version 1.9). Any guidance on how to update it PLEASE?
This is what I see (link to an image) https://imgbbb.com/image/LgzmGt
Thanks in advance!
what's your fw version ?
Where can I check that? On the main menu it says SX OS V 1.9. And then on the Homebrew part it says nx-hbmenu v2.0.0
 #16002  by Paperwings
 
Paperwings wrote: Fri Nov 15, 2019 12:38 am
Cronos wrote: Thu Nov 14, 2019 9:16 pm
Paperwings wrote: Thu Nov 14, 2019 2:43 pm It's not working for me. I haven't use my switch in like a year, so It's probably outdated (it says that it's version 1.9). Any guidance on how to update it PLEASE?
This is what I see (link to an image) https://imgbbb.com/image/LgzmGt
Thanks in advance!
what's your fw version ?
Where can I check that? On the main menu it says SX OS V 1.9. And then on the Homebrew part it says nx-hbmenu v2.0.0
So, I updated it to V2.9.2 and I'm still unable to make it work. I tried both Sword and Shield and xci and nsp. Am I missing something?